General Slowness

Incident Report for Rose Rocket Platform

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 20:37 UTC

Identified

We’ve identified the issue affecting performance due to a third party system. You may still experience delays. We are monitoring and will update as soon as possible.
Posted Aug 21, 2025 - 19:07 UTC

Investigating

We’re currently investigating a potential issue impacting performance. You may experience delays. We’ll provide updates as we learn more.
Posted Aug 21, 2025 - 18:19 UTC
This incident affected: Core Platform.