Rose Rocket Performance Degradation
Incident Report for Rose Rocket Platform
Resolved
This incident has been resolved and Rose Rocket functionality has now returned to normal.
Posted Oct 16, 2024 - 16:23 UTC
Investigating
We have received reports of users being unable to create orders and make changes to existing orders due to system performance degradation/slowness. Our team is currently investigating the issue.
Posted Oct 16, 2024 - 15:51 UTC
This incident affected: Core Platform and Customer/Shipper Portal.