Cloudflare global outage

Incident Report for Rose Rocket Platform

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:35 UTC

Monitoring

We are currently experiencing instability due to an outage affecting a core internet service provider (Cloudflare).
We are closely monitoring their recovery status.
Posted Nov 18, 2025 - 12:18 UTC
This incident affected: Core Platform.