System Slowness
Incident Report for Rose Rocket Platform
Resolved
This incident has been resolved and system performance has returned to normal.
Posted Nov 12, 2024 - 16:40 UTC
Investigating
We are currently experiencing system slowness. Our team is investigating. This page will be updated with progress.
Posted Nov 12, 2024 - 15:39 UTC
This incident affected: Core Platform.