System slowness, difficulty loading pages & boards

Incident Report for Rose Rocket Platform

Resolved

This incident has been resolved and performance should now have returned to normal.
Posted Mar 18, 2025 - 15:16 UTC

Investigating

Rose Rocket is currently experiencing issues with system slowness, loading pages and boards. You will see an increase in Red Toasts. We are investigating and will update accordingly.
Posted Mar 18, 2025 - 14:28 UTC
This incident affected: Core Platform.