Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 13, 2025 - 03:00 UTC
Scheduled
On April 12th, Rose Rocket Engineering will be performing database maintenance intended to further optimize Rose Rocket's performance and resiliency. This operation may be minimally disruptive to service and will occur between the hours of 11pm and 12am EST
Posted Apr 10, 2025 - 16:49 UTC
This scheduled maintenance affected: Core Platform, Analytics & Reports, and API + Integrations.